The issue has been resolved and emails are flowing as expected. Any emails sent during the outage window will send (or already have).
Posted Nov 07, 2024 - 05:48 PST
Update
Getting a little closer. Seems like they changed their transit carrier. Still having connectivity issues though.
Posted Nov 07, 2024 - 05:10 PST
Update
We are waiting for the underlying carrier to resolve the issue. We will provide an update when there is more information.
Posted Nov 07, 2024 - 04:29 PST
Update
We are waiting for the underlying carrier to resolve the issue. We will provide an update when there is more information.
Posted Nov 07, 2024 - 02:08 PST
Identified
We are currently working to resolve an issue regarding Email Delivery. Intermediary network services related to our Email Delivery edge network are experiencing routing issues which are preventing timely delivery of emails.
No emails have been lost, but there is a delay in delivery of emails.
Posted Nov 07, 2024 - 00:55 PST
This incident affected: Backend Services (Email Delivery).